Working with different HL7 versions

<< Click to Display Table of Contents >>

Navigation:  »No topics above this level«

Working with different HL7 versions

 

By default the UltraPort HL7 Notepad comes with ANSI definitions for HL7 versions 2.2, 2.3, 2.4, 2.5, 2.5.1 and 2.6.  The HL7 vendor definition contains information about the specific structure and all of the HL7 segments, fields and data types related to that particular version of HL7. While there is nothing wrong with using these "default" vendor definitions for the casual browsing and editing of HL7 messages we do recommend that you actually create your OWN vendor definitions for use if you need to alter them by adding custom segments, etc. You should (if at all possible) avoid modifying the "default" vendor definitions which come with the program since they have been constructed according to the ANSI standard. These definitions should be kept "in reserve" to be used as the basis for creating your own custom HL7 vendor definitions (see below).

 

Access the HL7 Vendor / Version Manager from the 'Tools' menu of the main window.

 

 

HL7 Vendor / Version Manager

HL7 Vendor / Version Manager

 

 

 

Modifying HL7 vendorsHL7 Vendor  / Version Properties

 

 

Creating HL7 vendorsCreating Your Own HL7 Vendor Definitions

 

Modifying HL7 vendorsAdding and Editing HL7 Segments